summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0acb17eae5..041018e0d2 100644
--- a/configure.in
+++ b/configure.in
@@ -27,7 +27,7 @@ AC_GETGROUPS_T
AC_RETSIGTYPE
AC_HAVE_FUNCS(getopt_long memmove strerror strtoul strdup strstr)
AC_HAVE_FUNCS(setenv fmod killpg mkdir strftime socket random)
-AC_HAVE_FUNCS(wait4 waitpid)
+AC_HAVE_FUNCS(wait4 waitpid syscall)
if echo $DEFS | grep "HAVE_SETENV" 2>&1 > /dev/null; then
:
else
@@ -38,7 +38,7 @@ if echo $DEFS | grep "HAVE_STRFTIME" 2>&1 > /dev/null; then
else
AC_TIMEZONE
AC_COMPILE_CHECK([daylight], [],
- [extern int daylight; daylight;], AC_DEFINE(HAVE_DAYLIGHT))
+ [extern int daylight; int i; i = daylight;], AC_DEFINE(HAVE_DAYLIGHT))
fi
AC_ALLOCA
AC_WORDS_BIGENDIAN