summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index afa29a70e0..31a007a941 100644
--- a/configure.in
+++ b/configure.in
@@ -610,6 +610,9 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes ;;
linux*) LDSHARED="$CC -shared"
rb_cv_dlopen=yes ;;
+ gnu*) LDSHARED="$CC -shared"
+ rb_cv_dlopen=yes
+ LDFLAGS="-rdynamic" ;;
freebsd*) LDSHARED="$CC -shared"
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="-rdynamic"
@@ -741,6 +744,8 @@ fi
case "$target_os" in
linux*)
STRIP='strip -S -x';;
+ gnu*)
+ STRIP='strip -S -x';;
nextstep*)
STRIP='strip -A -n';;
openstep*)
@@ -882,6 +887,10 @@ if test "$enable_shared" = 'yes'; then
LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_INSTALL_NAME).so.$(MAJOR).$(MINOR)'
LIBRUBY_ALIASES='lib$(RUBY_INSTALL_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_INSTALL_NAME).so'
;;
+ gnu*)
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_INSTALL_NAME).so.$(MAJOR).$(MINOR)'
+ LIBRUBY_ALIASES='lib$(RUBY_INSTALL_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_INSTALL_NAME).so'
+ ;;
freebsd*)
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_INSTALL_NAME).so.$(MAJOR)$(MINOR)'