summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 19 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 1a33cc0026..308371961f 100644
--- a/configure.in
+++ b/configure.in
@@ -792,14 +792,10 @@ if test "$enable_shared" = 'yes'; then
FIRSTMAKEFILE=GNUmakefile:cygwin/GNUmakefile.in
case "$target_os" in
cygwin*)
- LIBOBJS="$LIBOBJS strftime.o"
- CCDLFLAGS=-DUSEIMPORTLIB
- ;;
+ CCDLFLAGS=-DUSEIMPORTLIB ;;
mingw*)
- LIBOBJS="$LIBOBJS win32.o"
- CFLAGS="-DNT -D__MSVCRT__ $CFLAGS"
CCDLFLAGS=-DIMPORT
- ;;
+ SOLIBS='-lwsock32 -lmsvcrt' ;;
esac
;;
*)
@@ -808,16 +804,16 @@ if test "$enable_shared" = 'yes'; then
fi
case "$target_os" in
- nextstep*)
+ nextstep*)
CFLAGS="$CFLAGS -pipe"
- ;;
- openstep*)
+ ;;
+ openstep*)
CFLAGS="$CFLAGS -pipe"
- ;;
- rhasody*)
+ ;;
+ rhasody*)
CFLAGS="$CFLAGS -pipe -no-precomp"
- ;;
- osf*)
+ ;;
+ osf*)
if test "$without_gcc" = "no" ; then
CFLAGS="$CFLAGS -ansi"
else
@@ -835,8 +831,15 @@ case "$target_os" in
CFLAGS="$CFLAGS -std"
fi
;;
- *)
- ;;
+ cygwin*)
+ LIBOBJS="$LIBOBJS strftime.o"
+ ;;
+ mingw*)
+ LIBOBJS="$LIBOBJS win32.o"
+ CFLAGS="-DNT -D__MSVCRT__ $CFLAGS"
+ ;;
+ *)
+ ;;
esac
AC_SUBST(LIBRUBY_LDSHARED)
@@ -903,6 +906,6 @@ if test "$search_path" != ""; then
fi
echo "creating config.h"
-cat confdefs.h > config.h
+tr -d '\015' < confdefs.h > config.h
AC_OUTPUT($FIRSTMAKEFILE Makefile ext/extmk.rb)