summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 69ef552e44..0bae84de4c 100644
--- a/configure.in
+++ b/configure.in
@@ -158,6 +158,9 @@ rhapsody*) ;;
human*) ac_cv_func_getpgrp_void=yes;;
beos*) ;;
cygwin*) ;;
+os2_emx*) LIBS="-lm $LIBS"
+ ac_cv_lib_xpg4_setlocale=no
+ ac_cv_lib_dir_opendir=no;;
*) LIBS="-lm $LIBS";;
esac
AC_CHECK_LIB(crypt, crypt)
@@ -487,6 +490,7 @@ if test "$with_dln_a_out" != yes; then
aix*) LDSHARED='/usr/ccs/bin/ld'
XLDFLAGS='-Wl,-bE:ruby.imp'
DLDFLAGS='-eInit_$(TARGET) -bI:$(topdir)/ruby.imp -bM:SRE -T512 -H512 -lc'
+ LDFLAGS="-brtl"
rb_cv_dlopen=yes ;;
human*) DLDFLAGS=''
@@ -553,8 +557,8 @@ else
AC_DEFINE(DLEXT, ".bundle");;
cygwin*) DLEXT=dll
AC_DEFINE(DLEXT, ".dll");;
- os2_emx) DLEXT=o
- AC_DEFINE(DLEXT, ".so");;
+ os2_emx*) DLEXT=dll
+ AC_DEFINE(DLEXT, ".dll");;
*) DLEXT=so
AC_DEFINE(DLEXT, ".so");;
esac
@@ -638,7 +642,7 @@ rb_cv_missing_fconvert=yes, rb_cv_missing_fconvert=no, rb_cv_missing_fconvert=no
;;
dnl OS/2 environment w/ Autoconf 2.1x for EMX
os2_emx)
- LIBOBJS="$LIBOBJS os2.o"
+ LIBOBJS="$LIBOBJS os2.$OBJEXT"
setup=Setup.emx
;;
cygwin*)