summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e4356d9a65..e1380f9b3b 100644
--- a/configure.in
+++ b/configure.in
@@ -742,6 +742,7 @@ AC_SUBST(LIBEXT)dnl
STATIC=
LIBPATHFLAG=' -L%s'
+PATHFLAG=''
if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=unknown
@@ -814,7 +815,8 @@ if test "$with_dln_a_out" != yes; then
netbsd*) LDSHARED='${CC} -shared'
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="-Wl,-export-dynamic"
- LIBPATHFLAG=' -L%1$-s -Wl,-R%1$-s'
+ LIBPATHFLAG=' -L%1$-s'
+ RPATHFLAG=' -Wl,-R%1$-s'
fi
rb_cv_dlopen=yes ;;
openbsd*) LDSHARED="\$(CC) -shared ${CCDLFLAGS}"
@@ -887,6 +889,7 @@ if test "$with_dln_a_out" != yes; then
fi
AC_SUBST(LINK_SO)
AC_SUBST(LIBPATHFLAG)
+AC_SUBST(RPATHFLAG)
dln_a_out_works=no
if test "$ac_cv_header_a_out_h" = yes; then