summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index f1f7bd00fb..d152777c7b 100644
--- a/configure.in
+++ b/configure.in
@@ -539,6 +539,9 @@ rb_cv_missing_fconvert=yes, rb_cv_missing_fconvert=no)])
setup=Setup
;;
esac
+
+
+
AC_SUBST(binsuffix)
AC_SUBST(setup)
@@ -547,7 +550,7 @@ if test "$prefix" = NONE; then
fi
if test "$fat_binary" = yes ; then
- CFLAGS="$CFLAGS -pipe $ARCH_FLAG"
+ CFLAGS="$CFLAGS $ARCH_FLAG"
fi
LIBRUBY='libruby.a'
@@ -575,9 +578,19 @@ if test "$enable_shared" = 'yes'; then
LIBRUBYARG='-L./ -lruby'
fi
-if test "$host_os" = "rhapsody" ; then
- CFLAGS="$CFLAGS -no-precomp"
-fi
+case "$host_os" in
+ nextstep*)
+ CFLAGS="$CFLAGS -pipe"
+ ;;
+ openstep*)
+ CFLAGS="$CFLAGS -pipe"
+ ;;
+ rhasody*)
+ CFLAGS="$CFLAGS -pipe -no-precomp"
+ ;;
+ *)
+ ;;
+esac
AC_SUBST(LIBRUBY)