summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8fd3c33a9f..f20cf35440 100644
--- a/configure.in
+++ b/configure.in
@@ -281,6 +281,8 @@ mingw*)
;;
esac
+AC_CHECK_TYPES([long long, off_t])
+
AC_CHECK_SIZEOF(int, 4)
AC_CHECK_SIZEOF(short, 2)
AC_CHECK_SIZEOF(long, 4)
@@ -292,9 +294,6 @@ AC_CHECK_SIZEOF(float, 4)
AC_CHECK_SIZEOF(double, 8)
AC_CHECK_SIZEOF(time_t, 0)
-[test "${ac_cv_type_long_long}" = yes] && AC_DEFINE(HAVE_LONG_LONG)
-[test "${ac_cv_type_off_t}" = yes] && AC_DEFINE(HAVE_OFF_T)
-
dnl RUBY_REPLACE_TYPE [typename] [default type] [macro type] [included]
AC_DEFUN([RUBY_REPLACE_TYPE], [dnl
AC_CHECK_TYPE([$1],