summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index af0e564fcd..f6b0b57851 100644
--- a/configure.in
+++ b/configure.in
@@ -1294,9 +1294,10 @@ $POSTLINK"
[superux*], [ ac_cv_func_setitimer=no
],
[nacl], [
- LIBS="-lm -lnosys $LIBS"
+ LIBS="-lm $LIBS"
if test "${nacl_cv_build_variant}" = "newlib"; then
RUBY_APPEND_OPTION(CPPFLAGS, -DNACL_NEWLIB)
+ RUBY_APPEND_OPTION(LIBS, '-lnosys')
else
RUBY_APPEND_OPTION(XCFLAGS, -fPIC)
fi
@@ -2707,6 +2708,10 @@ AS_CASE("$enable_shared", [yes], [
[haiku], [
# gcc supports PIE, but doesn't work correctly in Haiku
pie=no
+ ],
+ [nacl], [
+ # -pie implies -shared for NaCl.
+ pie=no
])
if test "$GCC" = yes -a -z "$EXTSTATIC" -a "x$pie" != xno; then
RUBY_TRY_CFLAGS(-fPIE, [pie=yes], [pie=no])