summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 3 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index 73688088fc..62b34a8c62 100644
--- a/configure.in
+++ b/configure.in
@@ -522,7 +522,7 @@ AC_CHECK_HEADERS(stdlib.h string.h unistd.h limits.h sys/file.h sys/ioctl.h sys/
fcntl.h sys/fcntl.h sys/select.h sys/time.h sys/times.h sys/param.h\
syscall.h pwd.h grp.h a.out.h utime.h memory.h direct.h sys/resource.h \
sys/mkdev.h sys/utime.h netinet/in_systm.h float.h ieeefp.h pthread.h \
- intrinsics.h time.h)
+ ucontext.h intrinsics.h time.h)
dnl Check additional types.
AC_CHECK_SIZEOF(rlim_t, 0, [
@@ -1085,22 +1085,8 @@ if test x"$enable_pthread" = xyes; then
fi
fi
fi
-
-use_context=no
-if test x"$rb_with_pthread" = xyes; then
- AS_CASE("$target_cpu:$target_os:$cross_compiling",
- [*:linux*:no], [
- if test -n "`(/lib/libc.so.6 2>/dev/null | fgrep 'linuxthreads') 2> /dev/null`"; then
- use_context=yes
- fi
- ],
- [sparc*], [
- use_context=yes
- ])
-fi
-if test x"$use_context" = xyes; then
- AC_CHECK_HEADERS(ucontext.h)
- if test x"$ac_cv_header_ucontext_h" = xyes; then
+if test x"$ac_cv_header_ucontext_h" = xyes; then
+ if test x"$rb_with_pthread" = xyes; then
AC_CHECK_FUNCS(getcontext setcontext)
fi
fi