summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bd752d93d3..2d200a3235 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,6 +219,11 @@ AS_CASE(["$build_os:${CXX}"],
AC_MSG_RESULT([$CXX])],
[openbsd*:*], [
AC_CHECK_TOOLS(CXX, [c++])
+ ],
+ [solaris*:*], [
+ dnl C++ compiler of Sun OpenStudio is not supported
+ AS_CASE(["/$CC "],
+ [*@<:@\ /@:>@"cc "*], [CXX=no-c++])
])
test -z "$CXX" || ac_cv_prog_CXX="$CXX"