summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-01-30 06:03:02 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-01-30 06:03:02 +0000
commit342ed0b8575498f4f566d2972174b22381c85f56 (patch)
tree6ab1f552bfa3e8ec0646be3dc062f71be65fdf45 /configure.in
parent16c8a6d4b4588635a9009152392d62cc0f5d29c7 (diff)
merge revision(s) 44756:
* configure.in: use $@ instead of $(.TARGET) because .TARGET is not supported by GNU make. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@44757 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ea14b941ed..68da9e3f58 100644
--- a/configure.in
+++ b/configure.in
@@ -2656,7 +2656,7 @@ if test "$with_dln_a_out" != yes; then
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
else
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
fi