summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornagachika <nagachika@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-01-20 20:31:03 +0000
committernagachika <nagachika@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-01-20 20:31:03 +0000
commit12ef4f02289dfada188581578d6388d06654c0c5 (patch)
treefd1a865907fb4fdf8b65b84a431a516795c13e44 /configure.in
parente8402690742a2af5d7d0fa71943ac354c9833ae9 (diff)
merge revision(s) r44876,r47130,r48988,r48997: [Backport #10640] [Backport #10679]
configure.in: use C99 * configure.in: ISO9899:1999 is necessary for strtoll() on FreeBSD 10, (and may be possibly other platforms). * configure.in (NET_LUID): include also ifdef.h as a workaround of a bug in mingw-w64 header. [ruby-core:67103] [Bug #10640] * configure.in (NET_LUID): include winsock2.h instead of windows.h. patch by Jon Forums in [ruby-core:67125]. [Bug #10640] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@49356 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 11 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 5968bbdb14..6f8d9072e7 100644
--- a/configure.in
+++ b/configure.in
@@ -816,10 +816,13 @@ if test "$GCC" = yes; then
],
[
# ANSI (no XCFLAGS because this is C only)
- RUBY_TRY_CFLAGS(-ansi -std=iso9899:199409, [
- RUBY_APPEND_OPTION(warnflags, -ansi -std=iso9899:199409)
- RUBY_APPEND_OPTION(strict_warnflags, -ansi -std=iso9899:199409)
- ])
+ for ansi_options in -std=iso9899:1999 "-ansi -std=iso9899:199409"; do
+ RUBY_TRY_CFLAGS(${ansi_options}, [
+ RUBY_APPEND_OPTIONS(warnflags, ${ansi_options})
+ RUBY_APPEND_OPTIONS(strict_warnflags, ${ansi_options})
+ ], [ansi_options=])
+ test "x${ansi_options}" = x || break
+ done
])
# suppress annoying -Wstrict-overflow warnings
@@ -1054,8 +1057,8 @@ main()
ac_cv_func_malloc_usable_size=no
{ test "$target_cpu" = x64 && ac_cv_func___builtin_setjmp=no; }
AC_CHECK_TYPE([NET_LUID], [], [],
- [@%:@include <windows.h>
- @%:@include <iphlpapi.h>])
+ [@%:@include <winsock2.h>
+ @%:@include <iphlpapi.h>])
if test x"$ac_cv_type_NET_LUID" = xyes; then
AC_DEFINE(HAVE_TYPE_NET_LUID, 1)
fi
@@ -2699,7 +2702,7 @@ if test "$with_dln_a_out" != yes; then
RPATHFLAG=' +b %1$-s'
fi
rb_cv_dlopen=yes],
- [solaris*], [ if test "$GCC" = yes; then
+ [solaris*], [ if test "$GCC" = yes; then
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_prog_gnu_ld" = yes; then
LDFLAGS="$LDFLAGS -Wl,-E"
@@ -2818,7 +2821,7 @@ if test "$with_dln_a_out" != yes; then
[os2-emx*], [ LDFLAGS="$LDFLAGS -Zomf"
],
[nacl], [ LDSHARED='$(CC) -shared' ],
- [ : ${LDSHARED='$(LD)'}])
+ [ : ${LDSHARED='$(LD)'}])
AC_MSG_RESULT($rb_cv_dlopen)
fi
if test "${LDSHAREDXX}" = ""; then