summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-05-21 13:24:32 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-05-21 13:24:32 +0000
commitceea7ecef997411098fc0db3726897debbd9cdbf (patch)
tree31273e08ac860d934d5c34ea4607030091e3c00c /configure.in
parent118ee2a734152c35ebb6e963d4052d7152ab3ba0 (diff)
* configure.in (ALWAYS_INLINE): force compilers the function inlined.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@55101 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 52d97a6af8..9c4cd1812a 100644
--- a/configure.in
+++ b/configure.in
@@ -1807,6 +1807,7 @@ RUBY_FUNC_ATTRIBUTE(__deprecated__, DEPRECATED)
RUBY_FUNC_ATTRIBUTE(__deprecated__("by "@%:@n), DEPRECATED_BY(n,x), rb_cv_func_deprecated_by)
RUBY_TYPE_ATTRIBUTE(__deprecated__ mesg, DEPRECATED_TYPE(mesg,x), rb_cv_type_deprecated)
RUBY_FUNC_ATTRIBUTE(__noinline__, NOINLINE)
+RUBY_FUNC_ATTRIBUTE(__always_inline__, ALWAYS_INLINE)
RUBY_FUNC_ATTRIBUTE(__error__, ERRORFUNC)
RUBY_FUNC_ATTRIBUTE(__warning__, WARNINGFUNC)
RUBY_FUNC_ATTRIBUTE(__weak__, WEAK, rb_cv_func_weak)