summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-10-17 07:17:07 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-10-17 07:17:07 +0000
commit9bd24907851e390607d0d85365d0f00ed47a2a16 (patch)
tree4e674a999c3ee50481d1103804883463f9afc633 /configure.in
parent64b62f40a58408adf7f8fdebdf34ff02a5453d74 (diff)
install-static-library option [ci skip]
* configure.in (install-static-library): add option to enable/ disable to install static ruby library. defaulted to "no" if enable-shared. [Feature #12845] * tool/rbinstall.rb (local-arch-lib): respect the option. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@56434 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fe8ee14f79..87da5d85f8 100644
--- a/configure.in
+++ b/configure.in
@@ -4047,6 +4047,14 @@ AC_SUBST(CAPITARGET)
AS_CASE(["$RDOCTARGET:$CAPITARGET"],[nodoc:nodoc],[INSTALLDOC=nodoc],[INSTALLDOC=all])
AC_SUBST(INSTALLDOC)
+AC_ARG_ENABLE(install-static-library,
+ AS_HELP_STRING([--disable-install-static-library], [do not install static ruby library]),
+ [INSTALL_STATIC_LIBRARY=$enableval],
+ AS_IF([test x"$enable_shared" = xyes],
+ [INSTALL_STATIC_LIBRARY=no],
+ [INSTALL_STATIC_LIBRARY=yes]))
+AC_SUBST(INSTALL_STATIC_LIBRARY)
+
if test "$rb_with_pthread" = "yes"; then
THREAD_MODEL=pthread
fi