summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-11-13 13:28:00 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-11-13 13:28:00 +0000
commit2284d8b89bc55526096ff7535189005cb5a2438d (patch)
tree09e6acc5b583ac2804774f231bb7f96b7530b972 /configure.in
parentb141ac70ce9ca8a4af6c3f35273a40567ad158de (diff)
* configure.in: do not override CC if set.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_6@1833 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 641c703401..4dc1a979df 100644
--- a/configure.in
+++ b/configure.in
@@ -11,14 +11,14 @@ AC_SUBST(TEENY)
dnl checks for alternative programs
AC_ARG_WITH(gcc, [--without-gcc never use gcc], [
case $withval in
- no) CC=cc
+ no) : ${CC=cc}
without_gcc=yes;;
- yes) CC=gcc
+ yes) : ${CC=gcc}
without_gcc=no;;
*) CC=$withval
without_gcc=$withval;;
esac], [
- CC=gcc
+ : ${CC=gcc}
without_gcc=no])
dnl If the user switches compilers, we can't believe the cache
if test ! -z "$ac_cv_prog_CC" -a ! -z "$CC" -a "$CC" != "$ac_cv_prog_CC"