summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-12-25 06:36:18 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-12-25 06:36:18 +0000
commit0ebfc6f216f86a97d766d9ae2b525bd41b50286f (patch)
treef428f3c00df862b09847f9237b7004430e8908f9 /configure.in
parent913943270ddeeed3e7436017bc5976070328f112 (diff)
dir.c: replace_real_basename
* dir.c (replace_real_basename): get the real name and replace the base name with it by getattrlist(2) if available. suggested by Matthew Draper at [ruby-core:67116]. [Bug #10015] * dir.c (glob_helper): get the real name of the whole path, not only the last name. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@48990 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 97acc1a15f..ae08fa0956 100644
--- a/configure.in
+++ b/configure.in
@@ -1188,6 +1188,7 @@ AC_CHECK_HEADERS( \
malloc_np.h \
malloc/malloc.h \
setjmpex.h \
+ sys/attr.h \
sys/id.h
)
@@ -2038,6 +2039,7 @@ AC_CHECK_FUNCS(fmod)
AC_CHECK_FUNCS(fsync)
AC_CHECK_FUNCS(ftruncate)
AC_CHECK_FUNCS(ftruncate64) # used for Win32 platform
+AC_CHECK_FUNCS(getattrlist)
AC_CHECK_FUNCS(getcwd)
AC_CHECK_FUNCS(getgidx)
AC_CHECK_FUNCS(getgrnam)