summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-13 06:13:39 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-13 06:13:39 +0000
commitf82d652f35b594c63358cf06bdd242f3cb30b534 (patch)
treef59403032c3733ba9a25c1a5879f6b0c06bdae49 /configure.in
parent8e72bb717ab8613e25ac0c2e68cdff23fd905f04 (diff)
Fix dtrace commit r37631, it is [Feature #2565]
* configure.in: disable dtrace because it doesn't work on FreeBSD. * common.mk (clean-local): rm probes.h. * common.mk (parse.o): depend $(PROBES_H_INCLUDES). * common.mk (.d.h): moved from Makefile.in and use BASERUBY. * tool/gen_dummy_probes.rb: reimplemented with ruby because sed is not available on Windows Microsoft VC++ environment. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@37636 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d2ba707a7b..375d204e4b 100644
--- a/configure.in
+++ b/configure.in
@@ -374,6 +374,9 @@ if test x"${build}" != x"${host}"; then
fi
AC_CHECK_TOOL(DTRACE, dtrace)
+AS_CASE(["$target_os"],
+[freebsd*], [DTRACE=]
+)
AC_PROG_CC
AC_PROG_CXX