summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-09 19:43:24 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-09 19:43:24 +0000
commit99bb6a3f768c7981d99991905e61883b663e5fbb (patch)
treec56141281edd4b97f7ed5e26c49c13ee04f6574c /configure.in
parent53f011e662e74a846abf2c53ad2d1b096811f4f7 (diff)
* configure.in (RUBY_CHECK_SIZEOF): fix for fallback.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@22864 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 5b01e0fa69..c183b08212 100644
--- a/configure.in
+++ b/configure.in
@@ -341,6 +341,7 @@ AC_CACHE_CHECK([char bit], [rb_cv_char_bit],
[_AC_COMPUTE_INT_COMPILE([CHAR_BIT], [rb_cv_char_bit],
[AC_INCLUDES_DEFAULT([@%:@include <limits.h>])], [rb_cv_char_bit=8])])
+dnl RUBY_CHECK_SIZEOF [typename], [maybe same size types], [macros], [include]
AC_DEFUN([RUBY_CHECK_SIZEOF],
[if test "$universal_binary" = yes; then
AC_CACHE_CHECK([size of $1], [AS_TR_SH([ac_cv_sizeof_$1])], [dnl
@@ -373,18 +374,19 @@ AC_CACHE_CHECK([size of $1], [AS_TR_SH([ac_cv_sizeof_$1])], [dnl
done
done
}])
- _AC_COMPUTE_INT_COMPILE(AS_TR_CPP(SIZEOF_$1), [t], [AC_INCLUDES_DEFAULT([
-$cond
-@%:@else
+ _AC_COMPUTE_INT_COMPILE(AS_TR_CPP(SIZEOF_$1), [t], [AC_INCLUDES_DEFAULT([$4])]
+[${cond+$cond
+@%:@else}
typedef $1 ac__type_sizeof_;
@%:@define AS_TR_CPP(SIZEOF_$1) sizeof(ac__type_sizeof_)
-@%:@endif
+${cond+@%:@endif}
@%:@ifndef AS_TR_CPP(SIZEOF_$1)
@%:@define AS_TR_CPP(SIZEOF_$1) 0
-@%:@endif])], [unset t])
+@%:@endif], [unset t])
if test ${t-0} != 0; then
AS_TR_SH(ac_cv_sizeof_$1)="${AS_TR_SH(ac_cv_sizeof_$1)+${AS_TR_SH(ac_cv_sizeof_$1)-} }${t}"
fi
+ : ${AS_TR_SH(ac_cv_sizeof_$1)=0}
])
{
unset cond