summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-02-16 00:26:09 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-02-16 00:26:09 +0000
commit4ec9395ba2921ac9e5f2b900648b8e1879b4fa7a (patch)
tree4ffe9c4baa506b4f74aedc3061f710b707d17439 /configure.in
parent4f05bf852b2ccfd11dd6be7db9c54160711953ee (diff)
merge revision(s) 32730:
* configure.in (enable_pthread): use -pthread on OpenBSD without explicit option. patched by Jeremy Evans. [ruby-core:38572] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_3@34640 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c5acd71582..d645aa781a 100644
--- a/configure.in
+++ b/configure.in
@@ -1829,7 +1829,9 @@ if test x"$enable_pthread" = xyes; then
[c], [],
[root], [],
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
- [LIBS="-l$pthread_lib $LIBS"])
+ [AS_CASE(["$target_os"],
+ [openbsd*], [LIBS="-pthread $LIBS"],
+ [LIBS="-l$pthread_lib $LIBS"])])
else
AC_MSG_WARN("Don't know how to find pthread library on your system -- thread support disabled")
fi