summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-01-19 08:28:28 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-01-19 08:28:28 +0000
commit4e6ad7d910a27b9bddc9e3616464885184875ab4 (patch)
treedfdf0ac0093315a43c675f1b0f10fa63c61add33 /configure.in
parent49e685a0af54f3916542b4720da9b7e3f92e347d (diff)
* include/ruby/defines.h (RUBY_ALIAS_FUNCTION_TYPE): added.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@21666 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6f5a33695b..7a1970b401 100644
--- a/configure.in
+++ b/configure.in
@@ -473,10 +473,10 @@ if test "$GCC" = yes; then
[rb_cv_gcc_function_alias=$a; break])
done])
if test "$rb_cv_gcc_function_alias" != no; then
- AC_DEFINE_UNQUOTED([RUBY_ALIAS_FUNCTION2(type, prot, name, args)],
+ AC_DEFINE_UNQUOTED([RUBY_ALIAS_FUNCTION_TYPE(type, prot, name, args)],
[type prot __attribute__(($rb_cv_gcc_function_alias(@%:@name)));])
AC_DEFINE_UNQUOTED([RUBY_ALIAS_FUNCTION_VOID(prot, name, args)],
- [RUBY_ALIAS_FUNCTION2(void, prot, name, args)])
+ [RUBY_ALIAS_FUNCTION_TYPE(void, prot, name, args)])
fi
fi