summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-08-11 00:38:58 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-08-11 00:38:58 +0000
commite1fd55ae00adc7855f459383a22bb36b4de5ffa5 (patch)
treed740222f100ffc4ee5a02037ef13da80afa6e225 /configure.in
parent31a5ce34cdc4af831860fea87500f3870b42f90a (diff)
merges r32333 from trunk into ruby_1_9_2.
-- configure.in: Add warnflags for XL/C on AIX during configure to avoid [Bug #3971]. See [ruby-core:32859] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_2@32923 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8e481b748d..3f94ac8807 100644
--- a/configure.in
+++ b/configure.in
@@ -421,6 +421,9 @@ if test "$GCC:${warnflags+set}:no" = yes::no; then
[wflag=-Wall])
RUBY_TRY_CFLAGS($wflag, [warnflags="$wflag${warnflags+ $warnflags}"])
fi
+if test "$GCC" = ""; then
+ AS_CASE(["$target_os"],[aix*],[warnflags="-qinfo=por"])
+fi
if test "$GCC" = yes; then
if test "$visibility_option" = yes; then
RUBY_APPEND_OPTION(XCFLAGS, -fvisibility=hidden)