summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-02-18 10:43:45 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-02-18 10:43:45 +0000
commitb0416f342a2b2f43a17189fdbb24e53cef08e4ba (patch)
treea14772aca54b2ea53e12a3d382012ce9d4bb76eb /configure.in
parentb5296022863787b9bc9ce161cf1e02d381d0b722 (diff)
merges r30699 and r30700 from trunk into ruby_1_9_2.
-- * configure.in: Add #include<sys/stat.h> when struct stat is tested. Otherwise, incomplete type dereference error will occur. -- We don't only need to change "struct stat.st_size" test, but also need to change "struct stat.st_blocks" test. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_2@30900 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b08b33a6b8..7fba909f9d 100644
--- a/configure.in
+++ b/configure.in
@@ -1044,9 +1044,9 @@ RUBY_CHECK_SIZEOF(ptrdiff_t, size_t, [], [@%:@include <stddef.h>])
AC_STRUCT_ST_BLKSIZE
AC_STRUCT_ST_BLOCKS
AC_STRUCT_ST_RDEV
-RUBY_CHECK_SIZEOF([struct stat.st_size], [int long "long long"])
+RUBY_CHECK_SIZEOF([struct stat.st_size], [int long "long long"], [], [@%:@include <sys/stat.h>])
if test "$ac_cv_member_struct_stat_st_blocks" = yes; then
- RUBY_CHECK_SIZEOF([struct stat.st_blocks], [int long "long long"])
+ RUBY_CHECK_SIZEOF([struct stat.st_blocks], [int long "long long"], [], [@%:@include <sys/stat.h>])
fi
AC_CHECK_MEMBERS([struct stat.st_atim])
AC_CHECK_MEMBERS([struct stat.st_atimespec])