summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormame <mame@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-08-04 09:49:51 +0000
committermame <mame@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-08-04 09:49:51 +0000
commit6877a2de4c6106f279b6944f92efd480be4a8651 (patch)
tree3b5044fba7a5fddd9170e4a2413e9bda272cb5b8 /configure.in
parentf21f68a1a0320024dbb4e09bcc49e031de1ea643 (diff)
merges r28754, r28756 and r28777 from trunk into ruby_1_9_2.
These are needed to fix build failure on windows. [ruby-dev:41929] -- * configure.in: not [freebsd] but [freebsd*] for AS_CASE. * configure.in: define BROKEN_CLOSE only on FreeBSD. This needs to merge to 1.9.2. * configure.in: define BROKEN_CLOSE on FreeBSD. This fixes build failure on MSVC. [ruby-core:31481] * include/ruby/ruby.h, include/ruby/missing.h: use BROKEN_CLOSE for replacing close(2). git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_2@28852 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 760347141c..b3c5642fcf 100644
--- a/configure.in
+++ b/configure.in
@@ -1144,7 +1144,10 @@ main()
rb_cv_broken_glibc_ia64_erfc=no)])
AS_CASE([$rb_cv_broken_glibc_ia64_erfc],[yes],[ac_cv_func_erf=no])
-AS_CASE(["$target_os"],[freebsd],[],[AC_REPLACE_FUNCS(close)])
+AS_CASE(["$target_os"],[freebsd*],[
+ AC_DEFINE(BROKEN_CLOSE)
+ AC_REPLACE_FUNCS(close)
+ ])
AC_REPLACE_FUNCS(dup2 memmove strerror\
strchr strstr crypt flock\
isnan finite isinf hypot acosh erf tgamma lgamma_r cbrt \