summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-04-24 05:32:47 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-04-24 05:32:47 +0000
commit108c6a31efb21de3e3f55f03ba4eafb85cfecff9 (patch)
tree0399be5c7b116147d9171880c421ddd0fcf3a66a /configure.in
parent47ec225cf69289a505e4a50ce1bf0bcd0da87a10 (diff)
* configure.in: set size of the initial stack from
2MB to 32MB on MinGW/Cygwin. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_6@2405 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b7ce440003..cf7a3a0b98 100644
--- a/configure.in
+++ b/configure.in
@@ -620,6 +620,7 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes ;;
cygwin*|mingw*) : ${LDSHARED="${DLLWRAP} --target=${target_os} --as=${AS} --dlltool-name=${DLLTOOL} --driver-name=${CC} --export-all -s"}
rb_cv_dlopen=yes ;;
+ LDFLAGS='-Wl,--stack,0x02000000'
*) LDSHARED='ld' ;;
esac
AC_MSG_RESULT($rb_cv_dlopen)