summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>1998-07-29 09:50:58 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>1998-07-29 09:50:58 +0000
commit2562004338bc2694a7d8da75f4effcb9aa889641 (patch)
tree0af9582deace7d436b411552640555f90d7cd9fa /configure.in
parent3b0fec9a5f966fd7ae26bc7b84877fa7209d8605 (diff)
sync ev
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/v1_1r@280 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index f1f7bd00fb..d152777c7b 100644
--- a/configure.in
+++ b/configure.in
@@ -539,6 +539,9 @@ rb_cv_missing_fconvert=yes, rb_cv_missing_fconvert=no)])
setup=Setup
;;
esac
+
+
+
AC_SUBST(binsuffix)
AC_SUBST(setup)
@@ -547,7 +550,7 @@ if test "$prefix" = NONE; then
fi
if test "$fat_binary" = yes ; then
- CFLAGS="$CFLAGS -pipe $ARCH_FLAG"
+ CFLAGS="$CFLAGS $ARCH_FLAG"
fi
LIBRUBY='libruby.a'
@@ -575,9 +578,19 @@ if test "$enable_shared" = 'yes'; then
LIBRUBYARG='-L./ -lruby'
fi
-if test "$host_os" = "rhapsody" ; then
- CFLAGS="$CFLAGS -no-precomp"
-fi
+case "$host_os" in
+ nextstep*)
+ CFLAGS="$CFLAGS -pipe"
+ ;;
+ openstep*)
+ CFLAGS="$CFLAGS -pipe"
+ ;;
+ rhasody*)
+ CFLAGS="$CFLAGS -pipe -no-precomp"
+ ;;
+ *)
+ ;;
+esac
AC_SUBST(LIBRUBY)