summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-08-10 03:15:37 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-08-10 03:15:37 +0000
commitde0a9f726e49f6e97fd0d175675971a04e8c43de (patch)
tree2ad82546b309caca4a768a6a40a97344015dcb17 /configure.in
parente3d9fc76e62c8a1857abdafda948ff7d2918cfc8 (diff)
* configure.in,parse.y: removed garbage spaces.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@18470 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 15 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 1bfe6dc71a..083babbf9c 100644
--- a/configure.in
+++ b/configure.in
@@ -228,7 +228,7 @@ cygwin*|mingw*)
AC_TRY_LINK([#include <stdio.h>],
[FILE* volatile f = stdin; return 0;],
[rb_cv_msvcrt=`$OBJDUMP -p conftest$ac_exeext |
- tr A-Z a-z |
+ tr A-Z a-z |
sed -n '/^[[ ]]*dll name: \(msvc.*\)\.dll$/{s//\1/p;q;}'`],
[rb_cv_msvcrt=msvcrt])
test "$rb_cv_msvcrt" = "" && rb_cv_msvcrt=msvcrt])
@@ -834,7 +834,7 @@ fi
AC_CACHE_CHECK(for external int daylight, rb_cv_have_daylight,
[AC_TRY_LINK([#include <time.h>
int i;],
- [i = daylight;],
+ [i = daylight;],
rb_cv_have_daylight=yes,
rb_cv_have_daylight=no)])
if test "$rb_cv_have_daylight" = yes; then
@@ -1040,9 +1040,9 @@ else
; do
AC_TRY_COMPILE([#include <stdio.h>
],
- [FILE *f = stdin; char buf[256]; f->$frend = buf;],
- rb_cv_frend="$frend"; break,
- rb_cv_frend="not found")
+ [FILE *f = stdin; char buf[256]; f->$frend = buf;],
+ rb_cv_frend="$frend"; break,
+ rb_cv_frend="not found")
done])
if test "$rb_cv_frend" = "not found"; then
AC_MSG_RESULT([not found])
@@ -1108,7 +1108,7 @@ AC_DEFINE_UNQUOTED(STACK_GROW_DIRECTION, $rb_cv_stack_grow_dir)
if test x"$enable_pthread" = xyes; then
for pthread_lib in thr pthread pthreads c c_r root; do
- AC_CHECK_LIB($pthread_lib, pthread_kill,
+ AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
done
@@ -1125,7 +1125,7 @@ if test x"$enable_pthread" = xyes; then
MAINLIBS="-pthread $MAINLIBS"
;;
*)
- LIBS="-l$pthread_lib $LIBS"
+ LIBS="-l$pthread_lib $LIBS"
;;
esac
else
@@ -1306,7 +1306,7 @@ if test "$with_dln_a_out" != yes; then
solaris*) if test "$GCC" = yes; then
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_prog_gnu_ld" = yes; then
- LDFLAGS="$LDFLAGS -Wl,-E"
+ LDFLAGS="$LDFLAGS -Wl,-E"
fi
else
: ${LDSHARED='ld -G'}
@@ -1672,7 +1672,7 @@ if test "$enable_shared" = 'yes'; then
else # a.out platforms
LIBRUBY_ALIASES=""
fi
- ;;
+ ;;
openbsd*)
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_INSTALL_NAME).so.$(MAJOR).'`expr ${MINOR} \* 10 + ${TEENY}`
@@ -1685,7 +1685,7 @@ if test "$enable_shared" = 'yes'; then
LIBRUBY_DLDFLAGS="$DLDFLAGS "'-Wl,-h,$(@F)'
fi
XLDFLAGS="$XLDFLAGS "'-R${libdir}'
- ;;
+ ;;
hpux*)
XLDFLAGS="$XLDFLAGS "'-Wl,+s,+b,$(libdir)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).sl.$(MAJOR).$(MINOR).$(TEENY)'
@@ -1741,7 +1741,7 @@ case "$target_os" in
linux*)
;;
netbsd*)
- CFLAGS="$CFLAGS -pipe"
+ CFLAGS="$CFLAGS -pipe"
;;
nextstep*|openstep*)
# The -fno-common is needed if we wish to embed the Ruby interpreter
@@ -1751,18 +1751,18 @@ case "$target_os" in
# fails to consult /usr/local/include by default. This causes
# mkmf.rb's have_header() to fail if the desired resource happens to be
# installed in the /usr/local tree.
- CFLAGS="$CFLAGS -pipe -fno-common"
+ CFLAGS="$CFLAGS -pipe -fno-common"
CPPFLAGS="$CPPFLAGS -I/usr/local/include"
;;
rhapsody*)
- CFLAGS="$CFLAGS -pipe -no-precomp -fno-common"
+ CFLAGS="$CFLAGS -pipe -no-precomp -fno-common"
;;
darwin*)
- CFLAGS="$CFLAGS -pipe -fno-common"
+ CFLAGS="$CFLAGS -pipe -fno-common"
MINIDLNOBJ=dmydln.o
;;
os2-emx)
- CFLAGS="$CFLAGS -DOS2 -Zmts"
+ CFLAGS="$CFLAGS -DOS2 -Zmts"
LIBRUBY_A=`echo $LIBRUBY_A | sed 's/^lib//'`
LIBRUBY_SO=`echo $LIBRUBY_SO | sed 's/^lib//'`
LIBRUBY_ALIASES=`for i in $LIBRUBY_ALIASES; do echo "$i"; done | sed 's/^lib//'`