summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-08-09 23:15:08 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-08-09 23:15:08 +0000
commita64266a72837c350ac6552ac5cb14591b5cb2b05 (patch)
tree8fc8ade904dee168adf5d78483b31e9008442641 /configure.in
parent0e3d10173bec301c075555e20a0fc1da853ab35c (diff)
* configure.in (rb_cv_missing__dtos18, rb_cv_missing_fconvert),
ext/digest/md5/md5.c, ext/openssl/ossl.c (main), ext/socket/extconf.rb (ipv6, wide-getaddrinfo): main should be int. * main.c (main), win32/winmain.c, wince/wincemain.c (WinMain): envp is no longer used so long time. based on a patch from Peter Bowen at [ruby-core:18208] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@18459 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 8904ff89a5..1bfe6dc71a 100644
--- a/configure.in
+++ b/configure.in
@@ -1534,11 +1534,12 @@ case "$target_os" in
changequote(<<, >>)dnl
<<
#include <stdio.h>
-main ()
+int
+main()
{
char buf[256];
- sprintf (buf, "%g", 1e+300);
- exit (strcmp (buf, "1e+300") ? 0 : 1);
+ sprintf(buf, "%g", 1e+300);
+ return (strcmp (buf, "1e+300") ? 0 : 1);
}
>>,
changequote([, ])dnl
@@ -1553,11 +1554,12 @@ changequote(<<, >>)dnl
<<
#include <stdio.h>
#include <math.h>
-main ()
+int
+main()
{
char buf[256];
- sprintf (buf, "%f", log(exp(1.0)));
- exit (strcmp (buf, "1.000000") ? 0 : 1);
+ sprintf(buf, "%f", log(exp(1.0)));
+ return (strcmp (buf, "1.000000") ? 0 : 1);
}
>>,
changequote([, ])dnl