summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>1999-07-15 07:59:59 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>1999-07-15 07:59:59 +0000
commit86307f52ee1b3c5aa76e2fd6ee118e681dd76905 (patch)
tree4f5675ce901200d4245c6697d4e8d1c224949174 /configure.in
parente12510c502a3c8a81aeda66d1867eb1e760ce533 (diff)
990715
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_3@497 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 12 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 127a8efc20..3969fedfae 100644
--- a/configure.in
+++ b/configure.in
@@ -39,19 +39,11 @@ AC_ARG_ENABLE(fat-binary,
case "$host_os" in
rhapsody*)
echo -n "MacOS X Server: "
- if test "$TARGET_ARCHS" = "" ; then
- TARGET_ARCHS="ppc i386"
- fi
+ if test "$TARGET_ARCHS" = "" ; then
+ TARGET_ARCHS="ppc i386"
+ fi
;;
nextstep*|openstep*)
- echo -n "NeXTSTEP/OPENSTEP: "
-
- if test "$host_os" = "rhapsody" ; then
- echo -n "Rhapsody: "
- if test "$TARGET_ARCHS" = "" ; then
- TARGET_ARCHS="ppc i486"
- fi
- else
echo -n "NeXTSTEP/OPENSTEP: "
if test "$TARGET_ARCHS" = "" ; then
if test `/usr/bin/arch` = "m68k" ; then
@@ -60,7 +52,6 @@ AC_ARG_ENABLE(fat-binary,
TARGET_ARCHS="m68k `/usr/bin/arch`"
fi
fi
- fi
;;
esac
# /usr/lib/arch_tool -archify_list $TARGET_ARCHS
@@ -162,9 +153,10 @@ AC_CHECK_LIB(xpg4, setlocale) # FreeBSD needs this
dnl Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
+AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(stdlib.h unistd.h limits.h sys/file.h sys/ioctl.h pwd.h \
- sys/select.h sys/time.h sys/times.h sys/param.h sys/wait.h\
- syscall.h a.out.h string.h utime.h memory.h direct.h fnmatch.h)
+ sys/select.h sys/time.h sys/times.h sys/param.h syscall.h\
+ a.out.h string.h utime.h memory.h direct.h fnmatch.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_TYPE_UID_T
@@ -315,7 +307,7 @@ fi
dnl default value for $KANJI
AC_SUBST(DEFAULT_KCODE)
AC_ARG_WITH(default-kcode,
- [--with-default-kcode=CODE speficy default value for \$KCODE (utf8|euc|sjis|none)],
+ [--with-default-kcode=CODE specify default value for \$KCODE (utf8|euc|sjis|none)],
[case $withval in
utf8) AC_DEFINE(DEFAULT_KCODE, KCODE_UTF8);;
euc) AC_DEFINE(DEFAULT_KCODE, KCODE_EUC);;
@@ -786,6 +778,11 @@ fi
AC_DEFINE_UNQUOTED(RUBY_ARCHLIB, "${RUBY_LIB_PATH}/${arch}")
AC_DEFINE_UNQUOTED(RUBY_SITE_ARCHLIB, "${RUBY_SITE_LIB_PATH}/${arch}")
+AC_ARG_WITH(search-path,
+ [--with-search-path specify the additional search path],
+ [search_path=$withval])
+AC_DEFINE_UNQUOTED(RUBY_SEARCH_PATH,"$search_path")
+
echo "creating config.h"
cat confdefs.h > config.h