summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-04-01 02:36:21 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-04-01 02:36:21 +0000
commit71c0301736f60b74a0fe08eb58c2f6160fd278f5 (patch)
tree1523ade1b384abed5161a48cf15f6945447c00ea /configure.in
parent3950bd0151b13fde0851765476933c03240a4159 (diff)
* configure.in: _setjmp is available but _longjmp is not on mingw.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8@15877 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 23811bd70c..c56ad28069 100644
--- a/configure.in
+++ b/configure.in
@@ -569,7 +569,7 @@ AC_CHECK_FUNCS(fmod killpg wait4 waitpid syscall chroot fsync getcwd eaccess\
lchown lchmod getpgrp setpgrp getpgid setpgid initgroups\
getgroups setgroups getpriority getrlimit setrlimit sysconf\
group_member dlopen sigprocmask\
- sigaction sigsetjmp _setjmp setsid telldir seekdir fchmod\
+ sigaction sigsetjmp _setjmp _longjmp setsid telldir seekdir fchmod\
mktime timegm gettimeofday\
cosh sinh tanh round setuid setgid setenv unsetenv)
@@ -581,6 +581,8 @@ AC_CACHE_CHECK(for __builtin_setjmp, ac_cv_func___builtin_setjmp,
[ac_cv_func___builtin_setjmp=no])
])
+test $ac_cv_func__longjmp = no && ac_cv_func__setjmp=no
+
AC_MSG_CHECKING(for setjmp type)
AC_ARG_WITH(setjmp-type,
[ --with-setjmp-type select setjmp type], [
@@ -593,7 +595,7 @@ AC_ARG_WITH(setjmp-type,
*) AC_MSG_ERROR(invalid setjmp type: $withval);;
esac], [unset setjmp_prefix])
if test ${setjmp_prefix+set}; then
- if test "${setjmp_prefix}" && eval test '$ac_cv_'${setjmp_prefix}setjmp = no; then
+ if test "${setjmp_prefix}" && eval test '$ac_cv_func_'${setjmp_prefix}setjmp = no; then
AC_MSG_ERROR(${setjmp_prefix}setjmp is not available)
fi
elif test "$ac_cv_func___builtin_setjmp" = yes; then