summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-05-30 04:45:00 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-05-30 04:45:00 +0000
commitc1e6116aee2cfc0a6c11c41cf8b0c82601ee7dbe (patch)
tree9adc63f40358fe50c4f98b4fc12fb0782fa6cd2b /configure.in
parentb3498ae62d25047d62c6d58906a2512bfd2d8ddc (diff)
merges r31365 from trunk into ruby_1_9_2.
-- * configure.in (STRIP): use proper toolchain. based on a patch from Jon Forums at [ruby-core:35909]. fixes #4617 git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_2@31819 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index adcfddac96..8e481b748d 100644
--- a/configure.in
+++ b/configure.in
@@ -2009,18 +2009,17 @@ test ".$DLEXT" = "." || AC_DEFINE_UNQUOTED(DLEXT, ".$DLEXT")
test ".$DLEXT2" = "." || AC_DEFINE_UNQUOTED(DLEXT2, ".$DLEXT2")
AC_SUBST(DLEXT)
-AC_SUBST(STRIP)dnl
if test "$with_dln_a_out" = yes; then
STRIP=true
else
- STRIP=strip
+ AC_CHECK_TOOL(STRIP, strip, :)dnl
fi
AS_CASE(["$target_os"],
[linux* | gnu* | k*bsd*-gnu | kopensolaris*-gnu], [
- STRIP='strip -S -x'],
+ STRIP="$STRIP -S -x"],
[nextstep* | openstep* | rhapsody* | darwin*], [
- STRIP='strip -A -n'])
+ STRIP="$STRIP -A -n"])
AC_ARG_WITH(ext,
AC_HELP_STRING([--with-ext=EXTS],