summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-07-10 12:49:55 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-07-10 12:49:55 +0000
commitd85096ad454d8bffd41af18757c2bd63cac3f874 (patch)
tree2b7a82421e690bbccaa6ada61cc80c72c21a7711 /configure.in
parent4d23a784f5b001450715ef1d44ae2ef9fd06902b (diff)
compressed mantypes
* configure.in (--with-mantype): add compressed mantypes. * tool/rbinstall.rb (man): compress man pages if specified. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@51210 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 04767d07fd..aecbcdd8cd 100644
--- a/configure.in
+++ b/configure.in
@@ -4194,7 +4194,7 @@ AC_ARG_WITH(mantype,
AS_HELP_STRING([--with-mantype=TYPE], [specify man page type; TYPE is one of man and doc]),
[
AS_CASE(["$withval"],
- [man|doc], [MANTYPE=$withval],
+ [man|man.gz|man.bz2|doc|doc.gz|doc.bz2], [MANTYPE=$withval],
[AC_MSG_ERROR(invalid man type: $withval)])
])
if test -z "$MANTYPE"; then