summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2005-01-31 15:20:59 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2005-01-31 15:20:59 +0000
commit311352fe93d667102f2fe7460c8ede03f4dde908 (patch)
tree793d0675a95eb93606d90d18f6d7dd8bf3ed0f58 /configure.in
parent2a7b019a2dd498af081e49823da81d38f6300896 (diff)
* configure.in (aix): fix linker flags on AIX. [ruby-talk:125460]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8@7857 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 31356353fa..d0efd7feb4 100644
--- a/configure.in
+++ b/configure.in
@@ -894,11 +894,10 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes ;;
aix*) : ${LDSHARED='/usr/ccs/bin/ld'}
XLDFLAGS="$XLDFLAGS -Wl,-bE:ruby.imp"
- DLDFLAGS='-brtl -bI:$(topdir)/ruby.imp -bM:SRE -T512 -H512 '"$DLDFLAGS"
- ARCH_FLAG='-eInit_$(TARGET)'
- : LDFLAGS="-brtl $LDFLAGS"
+ DLDFLAGS='-brtl -eInit_$(TARGET) -bI:$(topdir)/ruby.imp -bM:SRE -T512 -H512 '"$DLDFLAGS"
+ LDFLAGS="-brtl $LDFLAGS"
: ${ARCHFILE="ruby.imp"}
- TRY_LINK='$(CC) $(DLDFLAGS) -oconftest $(INCFLAGS) -I$(hdrdir) $(CPPFLAGS) $(CFLAGS)'
+ TRY_LINK='$(CC) $(LDFLAGS) -oconftest $(INCFLAGS) -I$(hdrdir) $(CPPFLAGS) $(CFLAGS)'
TRY_LINK="$TRY_LINK"' $(src) $(LIBPATH) $(LOCAL_LIBS) $(LIBS)'
rb_cv_dlopen=yes ;;