summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-02-06 08:25:00 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-02-06 08:25:00 +0000
commit9601303a9526ff6e347caad0be046be5271d605f (patch)
tree08193db9e74b7c8a80d32a49bc0949b1e8c54783 /configure.in
parent56e671ba1ea062a145adea98e3b352b5c4844696 (diff)
* configure.in: keep old config.h unless changed.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_6@2050 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c2695e4279..4d09860335 100644
--- a/configure.in
+++ b/configure.in
@@ -1032,8 +1032,12 @@ if test "$search_path" != ""; then
AC_DEFINE_UNQUOTED(RUBY_SEARCH_PATH,"$search_path")
fi
-echo "creating config.h"
-tr -d '\015' < confdefs.h > config.h
+if test -f config.h && tr -d '\015' < confdefs.h | cmp -s config.h -; then
+ echo "config.h unchanged"
+else
+ echo "creating config.h"
+ tr -d '\015' < confdefs.h > config.h
+fi
: > confdefs.h
AC_OUTPUT($FIRSTMAKEFILE Makefile ext/extmk.rb)