summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-08-07 05:43:59 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-08-07 05:43:59 +0000
commit6f059f33ef1eae43e2648a6a8d4c8275b97a191e (patch)
tree9eb70930e68bf7d8f354c3f0d3d2ca369c5ce30d /configure.in
parent755dc335a511994e3b34a4abadb4a3332705c334 (diff)
* cygwin/GNUmakefile: better --disbale-shared option support.
* configure.in: Fix Cygwin specific naming of libraries to be net distribution compliant. (ruby-bugs PR#1077) cygwin-ruby18.dll -> cygruby18.dll git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@4350 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index ad200de61f..8486894869 100644
--- a/configure.in
+++ b/configure.in
@@ -1201,11 +1201,18 @@ case "$target_os" in
cygwin*|mingw*)
case "$target_os" in
cygwin*)
- RUBY_SO_NAME=$target_os-'$(RUBY_INSTALL_NAME)'${MAJOR}${MINOR}
+ if test x"$enable_shared" = xyes; then
+ LIBRUBY_SO='cyg$(RUBY_SO_NAME)'${MAJOR}${MINOR}.dll
+ LIBRUBY='lib$(RUBY_SO_NAME).dll.a'
+ fi
AC_LIBOBJ([strftime])
;;
mingw*)
RUBY_SO_NAME=msvcrt-'$(RUBY_INSTALL_NAME)'${MAJOR}${MINOR}
+ if test x"$enable_shared" = xyes; then
+ LIBRUBY_SO='$(RUBY_SO_NAME)'.dll
+ LIBRUBY='lib$(LIBRUBY_SO).a'
+ fi
AC_LIBOBJ([win32])
COMMON_LIBS=m
COMMON_MACROS="WIN32_LEAN_AND_MEAN="
@@ -1214,17 +1221,14 @@ case "$target_os" in
esac
XCFLAGS="$XCFLAGS"
LIBRUBY_DLDFLAGS="${DLDFLAGS}"' -Wl,--out-implib=$(LIBRUBY)'
- if test x"$enable_shared" = xyes; then
- LIBRUBY_SO='$(RUBY_SO_NAME)'.dll
- LIBRUBY='lib$(LIBRUBY_SO).a'
- else
+ LIBRUBY_ALIASES=''
+ FIRSTMAKEFILE=GNUmakefile:cygwin/GNUmakefile.in
+ SOLIBS='$(LIBS)'
+ if test x"$enable_shared" = xno; then
LIBRUBY_SO=dummy
LIBRUBY='lib$(RUBY_SO_NAME).a'
LIBRUBYARG='-l$(RUBY_SO_NAME)'
fi
- LIBRUBY_ALIASES=''
- FIRSTMAKEFILE=GNUmakefile:cygwin/GNUmakefile.in
- SOLIBS='$(LIBS)'
;;
hpux*)
case "$YACC" in