summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-03-13 09:15:46 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-03-13 09:15:46 +0000
commit844e89897c44a6c3486b27497e3df015e42813cf (patch)
tree97b96ee9153d244b65645ecb6547676c8e87e36d /configure.in
parent13adec97c9c4ad2aa8ea3edfd9c65710b703f51f (diff)
2000-03-13
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_4@639 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6bf1ba6931..2d7157340a 100644
--- a/configure.in
+++ b/configure.in
@@ -648,6 +648,7 @@ if test "$fat_binary" = yes ; then
CFLAGS="$CFLAGS $ARCH_FLAG"
fi
+FIRSTMAKEFILE=""
LIBRUBY_A='lib$(RUBY_INSTALL_NAME).a'
LIBRUBY='$(LIBRUBY_A)'
LIBRUBYARG='$(LIBRUBY_A)'
@@ -664,6 +665,7 @@ if test "$host_os" = "beos"; then
;;
i586*)
LDFLAGS="$LDFLAGS -L."
+ FIRSTMAKEFILE=GNUmakefile:beos/GNUmakefile.in
;;
*)
echo EXPORTS > ruby.def
@@ -672,7 +674,6 @@ if test "$host_os" = "beos"; then
esac
fi
-FIRSTMAKEFILE=""
LIBRUBY_LDSHARED=$LDSHARED
LIBRUBY_DLDFLAGS=$DLDFLAGS
LIBRUBY_SO='lib$(RUBY_INSTALL_NAME).so.$(MAJOR).$(MINOR).$(TEENY)'