summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-06-05 09:01:07 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-06-05 09:01:07 +0000
commit656d6d28704943d2960b20761b6d05386086e8a2 (patch)
treec99fec4f83ee9eb51430be6aaec27682c7dc6367 /configure.in
parent7f3aa8b9ea9aaf38f4167e95ba86dd5d3766554e (diff)
2000-06-05
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_4@732 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 88172cfcae..e4dde170fd 100644
--- a/configure.in
+++ b/configure.in
@@ -408,6 +408,7 @@ if test "$with_dln_a_out" != yes; then
netbsd*) CCDLFLAGS=-fpic
case "$host_cpu" in
mips*) CCDLFLAGS=-fPIC ;;
+ sparc) CCDLFLAGS=-fPIC ;;
*) ;;
esac ;;
*) CCDLFLAGS=-fPIC;;
@@ -415,7 +416,7 @@ if test "$with_dln_a_out" != yes; then
else
case "$host_os" in
hpux*) CCDLFLAGS='+z';;
- solaris*|irix*) CCDLFLAGS='-K PIC' ;;
+ solaris*|irix*) CCDLFLAGS='-KPIC' ;;
sunos*) CCDLFLAGS='-PIC' ;;
esix*|uxpds*) CCDLFLAGS='-KPIC' ;;
*) CCDLFLAGS='' ;;
@@ -436,7 +437,7 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes;;
sunos*) LDSHARED='ld -assert nodefinitions'
rb_cv_dlopen=yes;;
- irix*) LDSHARED='ld -ignore_unresolved'
+ irix*) LDSHARED='ld -shared'
rb_cv_dlopen=yes;;
sysv4*) LDSHARED='ld -G'
rb_cv_dlopen=yes;;
@@ -681,7 +682,6 @@ if test "$host_os" = "beos"; then
;;
i586*)
LDFLAGS="$LDFLAGS -L."
- FIRSTMAKEFILE=GNUmakefile:beos/GNUmakefile.in
;;
*)
echo EXPORTS > ruby.def