summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-01-25 09:00:50 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-01-25 09:00:50 +0000
commitcb2f5a91c12e9cd4798c7ba395924b8fdd1523ee (patch)
treed357dd5b219ff83c215bb53fa21e01fed14412e9 /configure.in
parent3b359789b92085ea0d1a2231b3d8ef279be9b63d (diff)
* configure.in (solaris): add '-shared' only for GNU ld.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_6@2017 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bce15f0001..c2695e4279 100644
--- a/configure.in
+++ b/configure.in
@@ -530,8 +530,11 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS="-Wl,-E"
rb_cv_dlopen=yes;;
solaris*) if test "$GCC" = yes; then
- LDSHARED='$(CC) -Wl,-G -shared'
- `$CC --print-prog-name=ld` -v 2>&1 | grep "GNU ld" > /dev/null && LDFLAGS="-Wl,-E"
+ LDSHARED='$(CC) -Wl,-G'
+ if `$CC --print-prog-name=ld` -v 2>&1 | grep "GNU ld" > /dev/null; then
+ LDFLAGS="-Wl,-E"
+ LDSHARED="$LDSHARED -shared"
+ fi
else
LDSHARED='ld -G'
fi