summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-06-07 20:55:30 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-06-07 20:55:30 +0000
commita2d87271fca38bd4048a5f1adb74ec70a93c02bf (patch)
tree82d2cff535c01a8e331d5fc98b08fdb052e28df9 /configure.in
parentb09f1c5d6ccd7cde63adb901d6483dde448be829 (diff)
merge revision(s) 14316:
* configure.in (TIMEZONE_VOID): check whether timezone requires zero arguments. [ruby-dev:32631] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8_6@17000 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c4f86267b1..9442cff8bf 100644
--- a/configure.in
+++ b/configure.in
@@ -595,6 +595,17 @@ RUBY_CHECK_VARTYPE(timezone, [#include <time.h>], [long int])
RUBY_CHECK_VARTYPE(altzone, [#include <time.h>], [long int])
if test "$rb_cv_var_timezone" = no; then
AC_CHECK_FUNCS(timezone)
+ if test "$ ac_cv_func_timezone" = yes; then
+ AC_CACHE_CHECK([whether timezone requires zero arguments], rb_cv_func_timezone_void,
+ [AC_TRY_COMPILE([#include <time.h>],
+ [(void)timezone(0, 0);],
+ [rb_cv_func_timezone_void=no],
+ [rb_cv_func_timezone_void=yes])]
+ )
+ if test $rb_cv_func_timezone_void = yes; then
+ AC_DEFINE(TIMEZONE_VOID)
+ fi
+ fi
fi
AC_CACHE_CHECK(for negative time_t for gmtime(3), rb_cv_negative_time_t,