summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2005-10-31 08:38:28 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2005-10-31 08:38:28 +0000
commit0107f4506b25a09973ab69aa6556586f77d1abd6 (patch)
tree6b7a51897a0d1cc4152cb03efb3175ea6df9fb58 /configure.in
parent8917210760260d07063904c7c923710014d92aae (diff)
* configure.in: use proper option for Sun linker. A patch from
Shinya Kuwamura <kuwa@labs.fujitsu.com>. [ruby-dev:27603] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8@9487 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2ab91c2e53..40dfdbc581 100644
--- a/configure.in
+++ b/configure.in
@@ -981,7 +981,11 @@ if test "$with_dln_a_out" != yes; then
[enable_rpath=$enableval], [enable_rpath="$rb_cv_binary_elf"])
if test "$enable_rpath" = yes; then
LIBPATHFLAG=" -L'%1\$-s'"
- RPATHFLAG=" -Wl,-R'%1\$-s'"
+ if test "$GCC" = yes; then
+ RPATHFLAG=" -Wl,-R'%1\$-s'"
+ else
+ RPATHFLAG=" -R'%1\$-s'"
+ fi
fi
fi
AC_SUBST(LINK_SO)