summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-02-18 10:37:47 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-02-18 10:37:47 +0000
commitb0e9e1d46892cf1b8c0373be8f05d0b0c711954b (patch)
tree0cd6efb52d3d780a7c86c487f29fa1910bdb7474 /configure.in
parent196d4a7d730eceaf2b9719a44d4c9778102e5724 (diff)
* configure.in: revert revision r29854. This revision introduced
binary incompatibilities on some circumstances. The bug that revision was fixing gets reopened by this reversion. [ruby-dev:43152] cf. [Bug #2553] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8_7@30895 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 3 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index 73688088fc..62b34a8c62 100644
--- a/configure.in
+++ b/configure.in
@@ -522,7 +522,7 @@ AC_CHECK_HEADERS(stdlib.h string.h unistd.h limits.h sys/file.h sys/ioctl.h sys/
fcntl.h sys/fcntl.h sys/select.h sys/time.h sys/times.h sys/param.h\
syscall.h pwd.h grp.h a.out.h utime.h memory.h direct.h sys/resource.h \
sys/mkdev.h sys/utime.h netinet/in_systm.h float.h ieeefp.h pthread.h \
- intrinsics.h time.h)
+ ucontext.h intrinsics.h time.h)
dnl Check additional types.
AC_CHECK_SIZEOF(rlim_t, 0, [
@@ -1085,22 +1085,8 @@ if test x"$enable_pthread" = xyes; then
fi
fi
fi
-
-use_context=no
-if test x"$rb_with_pthread" = xyes; then
- AS_CASE("$target_cpu:$target_os:$cross_compiling",
- [*:linux*:no], [
- if test -n "`(/lib/libc.so.6 2>/dev/null | fgrep 'linuxthreads') 2> /dev/null`"; then
- use_context=yes
- fi
- ],
- [sparc*], [
- use_context=yes
- ])
-fi
-if test x"$use_context" = xyes; then
- AC_CHECK_HEADERS(ucontext.h)
- if test x"$ac_cv_header_ucontext_h" = xyes; then
+if test x"$ac_cv_header_ucontext_h" = xyes; then
+ if test x"$rb_with_pthread" = xyes; then
AC_CHECK_FUNCS(getcontext setcontext)
fi
fi