summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-05-14 09:36:29 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-05-14 09:36:29 +0000
commit693599714a16c085f912dcddde16f52a18d2858b (patch)
treee7b00c267be0a21f0b09ddf83c3f2112df36dfa9 /configure.in
parent73667560792c0dc7bdbcd96b4ba56c65ba558506 (diff)
fix bug; support mingw32.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@690 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 19 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 1a33cc0026..308371961f 100644
--- a/configure.in
+++ b/configure.in
@@ -792,14 +792,10 @@ if test "$enable_shared" = 'yes'; then
FIRSTMAKEFILE=GNUmakefile:cygwin/GNUmakefile.in
case "$target_os" in
cygwin*)
- LIBOBJS="$LIBOBJS strftime.o"
- CCDLFLAGS=-DUSEIMPORTLIB
- ;;
+ CCDLFLAGS=-DUSEIMPORTLIB ;;
mingw*)
- LIBOBJS="$LIBOBJS win32.o"
- CFLAGS="-DNT -D__MSVCRT__ $CFLAGS"
CCDLFLAGS=-DIMPORT
- ;;
+ SOLIBS='-lwsock32 -lmsvcrt' ;;
esac
;;
*)
@@ -808,16 +804,16 @@ if test "$enable_shared" = 'yes'; then
fi
case "$target_os" in
- nextstep*)
+ nextstep*)
CFLAGS="$CFLAGS -pipe"
- ;;
- openstep*)
+ ;;
+ openstep*)
CFLAGS="$CFLAGS -pipe"
- ;;
- rhasody*)
+ ;;
+ rhasody*)
CFLAGS="$CFLAGS -pipe -no-precomp"
- ;;
- osf*)
+ ;;
+ osf*)
if test "$without_gcc" = "no" ; then
CFLAGS="$CFLAGS -ansi"
else
@@ -835,8 +831,15 @@ case "$target_os" in
CFLAGS="$CFLAGS -std"
fi
;;
- *)
- ;;
+ cygwin*)
+ LIBOBJS="$LIBOBJS strftime.o"
+ ;;
+ mingw*)
+ LIBOBJS="$LIBOBJS win32.o"
+ CFLAGS="-DNT -D__MSVCRT__ $CFLAGS"
+ ;;
+ *)
+ ;;
esac
AC_SUBST(LIBRUBY_LDSHARED)
@@ -903,6 +906,6 @@ if test "$search_path" != ""; then
fi
echo "creating config.h"
-cat confdefs.h > config.h
+tr -d '\015' < confdefs.h > config.h
AC_OUTPUT($FIRSTMAKEFILE Makefile ext/extmk.rb)