summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornagai <nagai@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-11-05 14:00:11 +0000
committernagai <nagai@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-11-05 14:00:11 +0000
commitea03c3fc2c0bfcf6351c3bce9496fd4607f4594a (patch)
tree6c121bf51ead591584872b4674497d233f7b37b5 /configure.in
parent4dada1c8a20c0fab0e058d7cd934c1c011617049 (diff)
configure.in, eval.c, signal.c: : add '--with-pthread-ext' option
to fix the pthread trouble on 'tcltklib' ext/tcltklib/README.1st: add the description of '--with-pthread-ext' ext/tk/lib/tktext.rb : add TkText#text_copy, text_cut, text_paste to support Tcl/Tk8.4's tk_textCopy, tk_textCut, tk_textPaste ext/tk/lib/tk.rb : add TkMenu#set_focus support Tcl/Tk's tk_menuSetFocus git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@4904 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e1380f9b3b..2f66c572d7 100644
--- a/configure.in
+++ b/configure.in
@@ -323,6 +323,7 @@ freebsd*) LIBS="-lm $LIBS"
if test "$rb_cv_supplementary_lib_c_r" = yes; then
MAINLIBS="-lc_r $MAINLIBS"
else
+ AC_DEFINE(HAVE_LIBPTHREAD)
MAINLIBS="-pthread $MAINLIBS"
CFLAGS="-D_THREAD_SAFE $CFLAGS"
fi
@@ -664,6 +665,11 @@ AC_DEFINE_UNQUOTED(STACK_GROW_DIRECTION, $rb_cv_stack_grow_dir)
dnl default value for $KANJI
DEFAULT_KCODE="KCODE_NONE"
+AC_ARG_WITH(pthread-ext,
+ [ --with-pthread-ext use pthread library on external modules ],
+ [AC_CHECK_LIB(pthread, pthread_mutex_trylock)
+ AC_DEFINE(USE_PTHREAD_EXTLIB)])
+
AC_ARG_WITH(default-kcode,
[ --with-default-kcode=CODE specify default value for \$KCODE (utf8|euc|sjis|none)],
[case $withval in