summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-07-30 00:32:03 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-07-30 00:32:03 +0000
commitdb8874aa1b41ddcebdf79b8ad1ef736028ef45e3 (patch)
treed98988df03efd0a9f114bce9fce5e5b35e88663d /configure.in
parentfe13785cc699692cefbdf94908fcaa7c99672f0f (diff)
* configure.in (os2-emx): renamed from os2_emx, add flags to
CFLAGS and LDFLAGS, and remove lib prefix. [ruby-dev:20993] * file.c (rb_file_s_rename): retry with removing new file on DOSISH. [ruby-dev:21007] * ext/socket/extconf.rb (sendmsg, recvmsg): check functions. * ext/socket/socket.c (unix_send_io, unix_recv_io): raise NotImplementedError unless system calls are available. * ext/socket/socket.c (sock_initialize): rename from sock_init() to get rid of conflict with OS/2 socket library. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@4221 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 13 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 11fb1a65ed..ad200de61f 100644
--- a/configure.in
+++ b/configure.in
@@ -288,7 +288,7 @@ mingw*) LIBS="-lwsock32 $LIBS"
ac_cv_func_telldir=yes
ac_cv_lib_crypt_crypt=no
;;
-os2_emx*) LIBS="-lm $LIBS"
+os2-emx*) LIBS="-lm $LIBS"
ac_cv_lib_dir_opendir=no;;
msdosdjgpp*) LIBS="-lm $LIBS"
ac_cv_func_getpgrp_void=yes;;
@@ -866,6 +866,8 @@ if test "$with_dln_a_out" != yes; then
hiuxmpp) LDSHARED='ld -r' ;;
atheos*) LDSHARED="$CC -shared"
rb_cv_dlopen=yes ;;
+ os2-emx*) LDFLAGS="$LDFLAGS -Zbsd-signals"
+ ;;
*) LDSHARED='ld' ;;
esac
AC_MSG_RESULT($rb_cv_dlopen)
@@ -913,7 +915,7 @@ else
AC_DEFINE(DLEXT, ".bundle");;
darwin*) DLEXT=bundle
AC_DEFINE(DLEXT, ".bundle");;
- os2_emx*) DLEXT=dll
+ os2-emx*) DLEXT=dll
AC_DEFINE(DLEXT, ".dll");;
cygwin*|mingw*) DLEXT=so
AC_DEFINE(DLEXT, ".so")
@@ -1006,7 +1008,7 @@ rb_cv_missing_fconvert=yes, rb_cv_missing_fconvert=no, rb_cv_missing_fconvert=no
setup=Setup.x68
;;
dnl OS/2 environment w/ Autoconf 2.1x for EMX
- os2_emx)
+ os2-emx)
AC_LIBOBJ([os2])
setup=Setup.emx
;;
@@ -1046,7 +1048,7 @@ LIBRUBYARG='$(LIBRUBYARG_STATIC)'
SOLIBS=
case "$target_os" in
- cygwin*|mingw*|beos*|openstep*|nextstep*|rhapsody*|darwin*|os2_emx*)
+ cygwin*|mingw*|beos*|openstep*|nextstep*|rhapsody*|darwin*|os2-emx*)
DLDLIBS=""
;;
*)
@@ -1167,8 +1169,11 @@ case "$target_os" in
darwin*)
CFLAGS="$CFLAGS -pipe"
;;
- os2_emx)
- CFLAGS="$CFLAGS -DOS2"
+ os2-emx)
+ CFLAGS="$CFLAGS -DOS2 -Zmts"
+ LIBRUBY_A=`echo $LIBRUBY_A | sed 's/^lib//'`
+ LIBRUBY_SO=`echo $LIBRUBY_SO | sed 's/^lib//'`
+ LIBRUBY_ALIASES=`for i in $LIBRUBY_ALIASES; do echo "$i"; done | sed 's/^lib//'`
;;
osf*)
if test "$GCC" != "yes" ; then
@@ -1279,7 +1284,7 @@ case "$target_os" in
;;
esac
case "$target_os" in
- cygwin*|mingw*|*djgpp*|os2_emx*)
+ cygwin*|mingw*|*djgpp*|os2-emx*)
RUBY_LIB_PREFIX="/lib/ruby"
;;
*)
@@ -1294,7 +1299,7 @@ AC_ARG_WITH(sitedir,
[sitedir='${prefix}/lib/ruby/site_ruby'])
SITE_DIR="`eval \"echo ${sitedir}\"`"
case "$target_os" in
- cygwin*|mingw*|*djgpp*|os2_emx*)
+ cygwin*|mingw*|*djgpp*|os2-emx*)
RUBY_SITE_LIB_PATH="`expr "$SITE_DIR" : "$prefix\(/.*\)"`" ||
RUBY_SITE_LIB_PATH="$SITE_DIR";;
*)