summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-12 02:46:40 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-12 02:46:40 +0000
commit9ac4ebbf2178d48ae7f844e02572f8662c91a589 (patch)
tree31f872a799812977354907912ed798b286635186 /configure.in
parentc6fe98f4a698bb9e34e224f2381975a260b3af19 (diff)
* configure.in (LIBPATHFLAG, RPATHFLAG): enclose paths with single
quotes. [ruby-dev:22564] * lib/mkmf.rb (libpathflag): do not enclose with quotes always. * {bcc32,win32,wince}/Makefile.sub (LIBPATHFLAG): quoted. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8@5442 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 3c07c4e402..9a2416c75c 100644
--- a/configure.in
+++ b/configure.in
@@ -799,7 +799,7 @@ AC_SUBST(DLEXT2)dnl
AC_SUBST(LIBEXT)dnl
STATIC=
-: ${LIBPATHFLAG=' -L%s'}
+: ${LIBPATHFLAG=" -L'%s'"}
: ${PATHFLAG=''}
if test "$with_dln_a_out" != yes; then
@@ -873,8 +873,8 @@ if test "$with_dln_a_out" != yes; then
netbsd*) : ${LDSHARED='${CC} -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
- LIBPATHFLAG=' -L%1$-s'
- RPATHFLAG=' -Wl,-R%1$-s'
+ LIBPATHFLAG=" -L'%1\$-s'"
+ RPATHFLAG=" -Wl,-R'%1\$-s'"
fi
rb_cv_dlopen=yes ;;
openbsd*) : ${LDSHARED="\$(CC) -shared ${CCDLFLAGS}"}