summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-12-31 10:53:14 +0000
committerknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-12-31 10:53:14 +0000
commit969bb67169be00b51533884b30376f7bcebefbf1 (patch)
treed2244b6c6a8ed4f60bc3fbc483fa0bbaa4d93112 /configure.in
parent653b0c120fb2ef2f1efe9df3c68c3e5cdb4afe09 (diff)
* configure.in: Improve OpenBSD support. [obtained from: OpenBSD
ports] * dln.c (FUNCNAME_PATTERN): Ditto. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@3252 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 63587211e1..7feac258b4 100644
--- a/configure.in
+++ b/configure.in
@@ -662,7 +662,7 @@ linux*)
else
LDFLAGS="-rdynamic"
fi;;
-netbsd*)
+netbsd*|openbsd*)
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
then
netbsd_elf=yes
@@ -758,7 +758,10 @@ if test "$with_dln_a_out" != yes; then
LIBPATHFLAG=' -L%1$-s -Wl,-R%1$-s'
fi
rb_cv_dlopen=yes ;;
- openbsd*) LDSHARED="ld -Bforcearchive -Bshareable"
+ openbsd*) LDSHARED="\$(CC) -shared ${CCDLFLAGS}"
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="-Wl,-E"
+ fi
rb_cv_dlopen=yes ;;
bsdi3*) case "$CC" in
*shlicc*) LDSHARED="$CC -r"
@@ -1056,7 +1059,8 @@ if test "$enable_shared" = 'yes'; then
;;
openbsd*)
SOLIBS='$(LIBS)'
- ;;
+ LIBRUBY_SO='lib$(RUBY_INSTALL_NAME).so.$(MAJOR).'`expr ${MINOR} \* 10 + ${TEENY}`
+ ;;
solaris*)
XLDFLAGS='-R${libdir}'
;;