summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-06-09 08:40:55 +0000
committerknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-06-09 08:40:55 +0000
commit1fddfcfb4813941a94ad305028839dbd1fc39ad3 (patch)
treebea8df21162cec0e737d2ed13e5abc996fb3cf38 /configure.in
parent1d664c874fa13818075ac690cc605a7b4483c392 (diff)
* config.guess, config.sub: Update to a more recent version as of
2004-01-20. * configure.in: Add support for DragonFly BSD. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8@6438 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 79464c9ff1..a299c766b2 100644
--- a/configure.in
+++ b/configure.in
@@ -348,6 +348,8 @@ freebsd*) LIBS="-lm $LIBS"
fi
fi
;;
+dragonfly*) LIBS="-lm $LIBS"
+ ;;
bow) ac_cv_func_setitimer=no
;;
superux*) ac_cv_func_setitimer=no
@@ -864,7 +866,7 @@ if test "$with_dln_a_out" != yes; then
gnu*) : ${LDSHARED="$CC -shared"}
rb_cv_dlopen=yes
LDFLAGS="$LDFLAGS -rdynamic" ;;
- freebsd*) : ${LDSHARED="$CC -shared"}
+ freebsd*|dragonfly*) : ${LDSHARED="$CC -shared"}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
@@ -1159,7 +1161,7 @@ if test "$enable_shared" = 'yes'; then
LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
;;
- freebsd*)
+ freebsd*|dragonfly*)
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'
if test "$rb_cv_binary_elf" != "yes" ; then