summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-03-04 06:13:24 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-03-04 06:13:24 +0000
commita38c2ac2dd0480502d83ad73fce54f25c993ab91 (patch)
treeb6e3ec6615b71927746903a9f0fbbdcb6a908584 /configure.in
parent196583d6eb70322e49ec9e54a0925828d3bda6d6 (diff)
* configure.in: better HP-UX support.
* missing/strftime.c: ditto. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@3550 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0ea68cca99..b67dab99b0 100644
--- a/configure.in
+++ b/configure.in
@@ -35,7 +35,7 @@ AC_SUBST(CPPOUTFILE)])
AC_DEFUN(RUBY_PROG_GNU_LD,
[AC_CACHE_CHECK(whether the linker is GNU ld, rb_cv_prog_gnu_ld,
-[if `$CC $CFLAGS $CPPFLAGS $LDFLAGS --print-prog-name=ld` -v 2>&1 | grep "GNU ld" > /dev/null; then
+[if `$CC $CFLAGS $CPPFLAGS $LDFLAGS --print-prog-name=ld 2>&1` -v 2>&1 | grep "GNU ld" > /dev/null; then
rb_cv_prog_gnu_ld=yes
else
rb_cv_prog_gnu_ld=no
@@ -262,6 +262,7 @@ nextstep*) ;;
openstep*) ;;
rhapsody*) ;;
darwin*) LIBS="-lobjc $LIBS";;
+hpux*) ac_cv_c_inline=no;;
human*) ac_cv_func_getpgrp_void=yes;;
beos*) ;;
cygwin*) rb_cv_have_daylight=no
@@ -730,7 +731,7 @@ if test "$with_dln_a_out" != yes; then
case "$target_os" in
hpux*) DLDFLAGS="-E"
LDSHARED='ld -b'
- LDFLAGS="-Wl,-E"
+ XLDFLAGS="-Wl,-E"
rb_cv_dlopen=yes;;
solaris*) if test "$GCC" = yes; then
LDSHARED='$(CC) -Wl,-G'