summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-10-02 07:48:42 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-10-02 07:48:42 +0000
commit9a46002fc01b1b874d768b2e8372b725a9e8b298 (patch)
tree9e3660449780967673d6a687f00329710e899537 /configure.in
parent173e2f6636701f7657a0acb3dcba33e9d66b562d (diff)
matz
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@985 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index e4dbcd166e..806e0869cf 100644
--- a/configure.in
+++ b/configure.in
@@ -57,9 +57,11 @@ AC_ARG_ENABLE(fat-binary,
# to ensure AC_HEADER_SYS_WAIT works
AC_DEFINE(_POSIX_SOURCE)
;;
- darwin*)
+ macos*|darwin*)
echo -n "MacOS X (Darwin): "
- TARGET_ARCHS="ppc"
+ if test "$TARGET_ARCHS" = "" ; then
+ TARGET_ARCHS="ppc i386"
+ fi
;;
esac
# /usr/lib/arch_tool -archify_list $TARGET_ARCHS
@@ -164,7 +166,7 @@ case "$target_os" in
nextstep*) ;;
openstep*) ;;
rhapsody*) ;;
-darwin*) ;;
+darwin*) LIBS="-lobjc $LIBS";;
human*) ac_cv_func_getpgrp_void=yes;;
beos*) ;;
cygwin*) rb_cv_have_daylight=no;;
@@ -731,7 +733,7 @@ LIBRUBYARG='$(LIBRUBY_A)'
SOLIBS=
case "$target_os" in
- cygwin*|mingw*|beos*|openstep*|nextstep*|rhapsody*|os2_emx*)
+ cygwin*|mingw*|beos*|openstep*|nextstep*|rhapsody*|darwin*|os2_emx*)
DLDLIBS=""
;;
*)
@@ -900,7 +902,7 @@ test "$program_suffix" != NONE &&
RUBY_INSTALL_NAME="${ri_prefix}ruby${ri_suffix}"
case "$target_os" in
- cygwin*|mingw*|*djgpp*)
+ cygwin*|mingw*|*djgpp*|os2_emx*)
RUBY_LIB_PREFIX="/lib/ruby"
;;
*)
@@ -913,9 +915,9 @@ AC_ARG_WITH(sitedir,
[--with-sitedir=DIR site libraries in DIR [PREFIX/lib/ruby/site_ruby]],
[sitedir=$withval],
[sitedir='${prefix}/lib/ruby/site_ruby'])
-SITE_DIR="`eval "echo ${sitedir}"`"
+SITE_DIR="`eval \"echo ${sitedir}\"`"
case "$target_os" in
- cygwin*|mingw*|*djgpp*)
+ cygwin*|mingw*|*djgpp*|os2_emx*)
RUBY_SITE_LIB_PATH="`expr "$SITE_DIR" : "$prefix\(/.*\)"`" ||
RUBY_SITE_LIB_PATH="$SITE_DIR";;
*)