summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-05-02 18:35:50 +0000
committerknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-05-02 18:35:50 +0000
commitf0448281f577fa930c68fb900d30c20c78f75914 (patch)
tree021465f712992678f8902147e2b31dfd3c7332c2 /configure.in
parenteb0d3500d3879e320a37dafbc888f971201cb8d3 (diff)
I'm committing this from a MacOS X host. :)
* configure.in: get --enable-shared to work on MacOS X. * Makefile.in: make $(LIBRUBY_SO) depend on miniruby properly. Now `make -jN' should work without a problem. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@1360 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 379e880ec4..b275a2bcb1 100644
--- a/configure.in
+++ b/configure.in
@@ -554,7 +554,7 @@ if test "$with_dln_a_out" != yes; then
nextstep*) ;;
openstep*) ;;
rhapsody*) ;;
- darwin*) ;;
+ darwin*) CCDLFLAGS=-fno-common;;
human*) ;;
bsdi*) ;;
beos*) ;;
@@ -916,6 +916,12 @@ if test "$enable_shared" = 'yes'; then
;;
esac
;;
+ darwin*)
+ LIBRUBY_SO='lib$(RUBY_INSTALL_NAME).$(MAJOR).$(MINOR).$(TEENY).dylib'
+ LIBRUBY_LDSHARED='cc -dynamiclib -undefined suppress'
+ LIBRUBY_DLDFLAGS='-install_name lib$(RUBY_INSTALL_NAME).dylib -current_version $(MAJOR).$(MINOR).$(TEENY) -compatibility_version $(MAJOR).$(MINOR)'
+ LIBRUBY_ALIASES='lib$(RUBY_INSTALL_NAME).$(MAJOR).$(MINOR).dylib lib$(RUBY_INSTALL_NAME).dylib'
+ ;;
*)
;;
esac