summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-02-26 05:29:06 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-02-26 05:29:06 +0000
commitdf2d69b49ab1c8b42dd6c18fb63df26aec95f364 (patch)
treef352837db7633a5d6355461ca14f0f870d951e86 /configure.in
parent69739b14a5f8950c1da8b86f90a70903ed975fee (diff)
* eval.c (proc_call): should not modify ruby_block->frame.iter
based on ruby_frame->iter altered by PUSH_ITER(). * eval.c (rb_thread_fd_close): should save current context before raising exception. * io.c (set_stdin): preserve original stdin. * io.c (set_outfile): preserve original stdout/stderr. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@1219 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9d42330a2a..ebdb0fd498 100644
--- a/configure.in
+++ b/configure.in
@@ -270,7 +270,8 @@ check(tm, y, m, d, h, s)
struct tm *tm;
int y, m, d, h, s;
{
- if (tm->tm_year != y ||
+ if (!tm ||
+ tm->tm_year != y ||
tm->tm_mon != m-1 ||
tm->tm_mday != d ||
tm->tm_hour != h ||